搭建区块链浏览器所遇到的问题3-如何更改linux中gradle的版本

本文最后更新于:3 months ago

单独拿出来说是因为这又是一个悲惨的故事了,
关于如何更改linux中gradle的版本这个我问题,我查非常多的资料
唉,也花了一个多小时。。。

Ubuntu中如果让系统帮你自己安装Gradle要么是

1
sudo snap install Gradle

这里安装的是7.0以上的版本,不符合我们需要的7.0以下的版本

要么是

1
sudo apt install Gradle

这里安装的是4.10一下的版本,也不符合官方给的5.0以上的需求。。。

那只有我们自己找了,好不容易好不容易好不容易将Gradle安装好了,环境变量也配置好了之后
并且我将原先安装的Gradle7.0版本卸载之后,满怀欣喜的输入 gradle -v

然后。。。

1
gradle:未找到命令

一种植物。。。
这谁顶得住啊,明明环境变量都配置好了还是这样

然后继续查资料。。。然后一直在找这个问题

最后什么都没有解决我的问题。。。根本没找到,用了snap卸载的方法也还是不行

我急中生智,先用

1
sudo apt install Gradle

命令安装4.10版本的Gradle,然后在

1
sudo apt remove Gradle

接着,我再自己下载Gradle压缩包,配置环境,没想到竟然成了。。。


Gradle命令是配好了

但接下来又遇到了其他问题,运行脚本的时候,又爆出这个错误:

1
bash: /usr/local/gradle-5.4.1-all/gradle-5.4.1/bin/gradle: 权限不够

这个还好,能看得懂是为什么,就是权限不够:

1
chmod +x ${location}/gradle-4.9/bin/gradle

于是就成功了😭,放一下我解决这个问题查找的博文,还有很多小的地方就不介绍了,主要是这三个问题比较难解决,其他的也花了很多时间,但网上也有相应的资料,MySQL的安装,java环境配置,python环境配置以及PyMySQL的安装